トップ  > OpenPNE2  > 豆知識  > 記事

No.1581 OpenPNEの設置環境

OpenPNE は以下のようなサーバ環境で動作させることを想定しています。

Webサーバ
    Apache を推奨
PHP
    PHP 4.3.3 以降 / 5.0.x / 5.1.x

        * PHP の mbstring 拡張モジュールを使用可能
        * PHP の XML 拡張モジュールを使用可能
        * PHP の PCRE 拡張モジュールを使用可能 (UTF-8 サポート)
        * PHP から GD ライブラリを使用可能 (JPEG/GIF/PNG サポート)
              o ImageMagick を使う場合でも必要となります
        * PHP の mcrypt 拡張モジュールの使用を推奨

データベースサーバ
    PostgreSQL 7.4.x / 8.0.x / 8.1.x (※8.2.x 以降は未対応です)
メールサーバ (携帯からメール投稿する場合)
    Postfix 2.1.x 以降を推奨 (Postfix 以外のメールサーバでも動作報告あり)

更新:2009/10/07 16:53 カテゴリ: OpenPNE2  > 豆知識 ▲トップ

FuelPHP

Mac

フロントエンド開発

web開発

プロマネ

マネタイズ

プレゼン

webサービス運用

webサービス

Linux

サーバ管理

MySQL

ソース・開発

svn・git

PHP

HTML・CSS

JavaScript

ツール, ライブラリ

ビジネス

テンプレート

負荷・チューニング

Windows

メール

メール・手紙文例

CodeIgniter

オブジェクト指向

UI・フロントエンド

cloud

マークアップ・テキスト

Flash

デザイン

DBその他

Ruby

PostgreSQL

ユーティリティ・ソフト

Firefox

ハードウェア

Google

symfony

OpenPNE全般

OpenPNE2

Hack(賢コツ)

OpenPNE3

リンク

個人開発

その他

未確認

KVS

ubuntu

Android

負荷試験

オープンソース

社会

便利ツール

マネー

Twig

食品宅配

WEB設計

オーディオ

一般常識

アプリ開発

Python

サイトマップ

うずら技術ブログ

たませんSNS

rss2.0